2005 1000DS SS oil light shut down - ducati.org forum | the home for ducati owners and enthusiasts

Remember me
Login  |   Register

ducati.org forum | the home for ducati owners and enthusiasts > Regional Areas - International > Australia

Like Tree1Likes
  • 1 Post By Shrek
Reply
 
LinkBack Thread Tools Display Modes
Old February 24th, 2019, 02:26 AM   #1
Junior Member

No ducatis in the registry

 
Join Date: Jul 2018
Posts: 3
2005 1000DS SS oil light shut down

Any help would be appreciated. The bike has on a few occasions shut down while riding . The oil light comes on and appears to have no fuel or ignition. The oil sensor was replaced about 4 months ago and all has been fine until now. When I pull over and shut the girl down, I restart the girl and the light is gone and off I go again. Have done an oil and filter change, removed tank and clean,checked the oil sensors and cleaned them. Bewildered, ps the bike is fuel injected.

Any thoughts cheers Wayno
Wayno is offline   Reply With Quote
Remove Ads
Old February 24th, 2019, 03:16 PM   #2
Senior Member

No ducatis in the registry

 
Join Date: Dec 2013
Posts: 559
Hey Iíve got a 1000ds and a 900is Supersport. Doesnít sound like an oil light issue nor a connection issue..
Now Iím not an expert although I do all my own work on my bikes. So take this in consideration.
It might be time consuming but Iíd start at the front and check and clean all me connections , ignition, fuses ect.
racer162 is offline   Reply With Quote
Old February 25th, 2019, 01:56 AM   #3
Junior Member

No ducatis in the registry

 
Join Date: Jul 2018
Posts: 3
Racer 162 thanks for the reply it is much appreciated. Yes I have started to trace back all wiring and check but so far everything is clean and smick. Have ordered an new sensor to give it a try as found a little bit of oil in the top and apparently they are known for leaking past the valve. Just hate the electrical issues very hard to figure them out.
Cheers and thanks again. Wayno
Wayno is offline   Reply With Quote
Old February 25th, 2019, 02:21 AM   #4
Senior Member

No ducatis in the registry

 
Join Date: Dec 2013
Posts: 559
Yeah I had the oil sensor on the 900 leak and replaced it but never had a shut down due to it ( knock on wood)
Iíll be interested to hear what happens. Reminds me Iíve got this SS1000ds project I should clean that harness tomorrow lol.
racer162 is offline   Reply With Quote
Old February 25th, 2019, 03:44 AM   #5
Senior Member

No ducatis in the registry

 
Shrek's Avatar
 
Join Date: Feb 2008
Location: Chief Cook and Bottlewash
Posts: 5,837
Not an oil pressure issue.. it’s not connected to the ecu like that. Light comes on because the ignition is cutting. Look at side stand switch and the kill switch circuit.. is the mill switch cluster looking in ok condition or pretty ratty? Could be a dodgy fuse or relay.. your description didn’t, or i didn’t, read to describe the shut down. Is it a hard cut or cough spluttering cut out? I was guessing on a hard cut.
Svensken likes this.
__________________
*****************************
Quote:
Originally Posted by X I M View Post
The reality of this situation maybe obscured by living room curtains.
*****************************
Shrek is offline   Reply With Quote
Old March 1st, 2019, 09:27 PM   #6
Junior Member

No ducatis in the registry

 
Join Date: Jul 2018
Posts: 3
Racer 162, Shrek Thanks for the replies again and help. Shrek it was a hard cut out absolutely. Side stand all good with the multi meter , mill switch looks in okay condition and checked all fuses they all looked fine but cleaned them anyway. It has an Power commander lll unit fitted which I got put on last year and dyno tuned for low down talk do you think this may be cutting the ECU unit down. Have put the new oil pressure censor on checked all my wiring again took it for a rid this arvo and light hasnt come on yet. Ride was for about 1/2 an hour just around town as to bloody scared to push it out on the highway in case she shuts down and wont start. I guess we have all been through that drama gaining the trust back into the bike.
Thanks for your help i is much appreciated cheers .
Wayno is offline   Reply With Quote
Reply

Thread Tools
Display Modes


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On


Similar Threads
Thread Thread Starter Forum Replies Last Post
Flickering oil light socalbiker Technical 11 May 21st, 2010 03:28 PM
Flashing Oil Light Bad Karma 848 10 June 19th, 2008 03:49 PM
Bad Service at Spectrum in Irvine strobman99 West 5 July 27th, 2007 12:36 PM



All times are GMT -7. The time now is 10:57 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.