Exhaust pipe and radiator hose heating than usual with werkes exhaust? - ducati.org forum | the home for ducati owners and enthusiasts

Remember me
Login  |   Register

ducati.org forum | the home for ducati owners and enthusiasts > Ducati Monster Forums > Ducati Monster 821

Reply
 
LinkBack Thread Tools Display Modes
Old September 11th, 2019, 01:12 AM   #1
Member

No ducatis in the registry

 
Join Date: Jan 2019
Posts: 44
Exhaust pipe and radiator hose heating than usual with werkes exhaust?

Hi guys finally installed the competition werkes carbon fiber gp slip on exhaust with baffles on m821 18 and quite happy with the sound infact it sound the best for monster...it feels lean no excessive cracking or popping or flat spot mid range power is slightly reduced a bit i guess
One issue i have is:
The exhaust header and mid pipe ,radiator hose pipes is heating a lot than usual but temperature on odo is normal infact it shows 3-4 degree cooler on an average as compared to stock..
Any leads why this is happning ?
Is the temperature guage working all fine or is the new exhaust creating a confusion for the ecu or sensors?
Or this is jus normal and i dont need to worry abt it or will this be fixed with?

New mods
👇🏻
Name:  49B17E10-39D5-4671-B42B-4B8757ECC940.jpeg
Views: 85
Size:  3.58 MB
Thankyou guy from this forum got the perfect stuff jus coz by discussing
Harsha821 is offline   Reply With Quote
Remove Ads
Old September 11th, 2019, 10:47 AM   #2
Member

No ducatis in the registry

 
omgwtfxu's Avatar
 
Join Date: Sep 2017
Location: SoCal Los Angeles Area
Posts: 53
Quote:
Originally Posted by Harsha821 View Post
Hi guys finally installed the competition werkes carbon fiber gp slip on exhaust with baffles on m821 18 and quite happy with the sound infact it sound the best for monster...it feels lean no excessive cracking or popping or flat spot mid range power is slightly reduced a bit i guess

One issue i have is:

The exhaust header and mid pipe ,radiator hose pipes is heating a lot than usual but temperature on odo is normal infact it shows 3-4 degree cooler on an average as compared to stock..

Any leads why this is happning ?

Is the temperature guage working all fine or is the new exhaust creating a confusion for the ecu or sensors?

Or this is jus normal and i dont need to worry abt it or will this be fixed with?



New mods



Attachment 168031

Thankyou guy from this forum got the perfect stuff jus coz by discussing


Sounds even meaner with the baffle out


Sent from my iPhone using Tapatalk
omgwtfxu is offline   Reply With Quote
Old September 12th, 2019, 02:34 AM   #3
Junior Member

No ducatis in the registry

 
Join Date: Sep 2019
Posts: 3
Get it tuned!
nicedart is offline   Reply With Quote
Reply

Thread Tools
Display Modes


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -7. The time now is 10:21 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.