Troubles with turn signals - ducati.org forum | the home for ducati owners and enthusiasts

Remember me
Login  |   Register

ducati.org forum | the home for ducati owners and enthusiasts > Ducati Monster Forums > Monster

Reply
 
LinkBack Thread Tools Display Modes
Old January 31st, 2020, 10:21 AM   #1
Junior Member

No ducatis in the registry

 
Join Date: Jan 2020
Posts: 1
Troubles with turn signals

I bought a 1997 M900 last year and my dad and I have been. slowly getting everything into good shape. Overall pretty good condition. When I bought it the previous owner had installed LED turn signals and they worked for a couple months then all the sudden they quit working and we have checked the relay and even put on new LED turn signals and made sure they were installed correctly but still we do not get anything other then when I use the switch whether I do left or right they all just become very dimly lit. Anyone have any ideas as to what is going on?
1997 M900 Owner is offline   Reply With Quote
Remove Ads
Reply

Thread Tools
Display Modes


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -7. The time now is 09:00 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2020, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2020 DragonByte Technologies Ltd.