Looking for someone with a known working ecu to try - ducati.org forum | the home for ducati owners and enthusiasts

Remember me
Login  |   Register

ducati.org forum | the home for ducati owners and enthusiasts > Regional Areas - USA > Southeast

Reply
 
LinkBack Thread Tools Display Modes
Old October 14th, 2019, 11:18 AM   #1
Junior Member

No ducatis in the registry

 
Join Date: Oct 2019
Posts: 3
Looking for someone with a known working ecu to try

Hi Everyone,

I'm not really sure where to put this, but I'm hoping here is a good spot to find someone local. I'm in the Tampa area and have a 99 ST4 with the 16M ecu. I think it's dead so if anyone local has one I could try, that would be awesome.

A lot of different bikes come with the 16M. All We have to do is swap the eprom. I'll buy you beer or pay whatever is fair and I can bring the bike to you.

Thanks in advance,

Craig
hydroshok is offline   Reply With Quote
Remove Ads
Old October 14th, 2019, 09:29 PM   #2
Sox
Member

No ducatis in the registry

 
Join Date: Jul 2018
Posts: 31
im in Palm Harbor,,,, 1198,,,,,,not sure if a 1198 ecu would work....but i have a spare ecu
Sox is offline   Reply With Quote
Old October 15th, 2019, 08:51 AM   #3
Junior Member

No ducatis in the registry

 
Join Date: Oct 2019
Posts: 3
Thanks for the response. I don't think it will, but mine looks like the one in this link. If yours looks similar, we could give it a shot.

https://www.ebay.com/itm/DUCATI-OEM-...ss!33540!US!-1
hydroshok is offline   Reply With Quote
Old October 19th, 2019, 06:39 AM   #4
Sox
Member

No ducatis in the registry

 
Join Date: Jul 2018
Posts: 31
nope....not the same,,,,

whats going on with your bike? i have friends throughout Florida that I rely on when i have problem like yours

so explain what is doing or not doing ,,,and i will ask some of my friends
Sox is offline   Reply With Quote
Old October 23rd, 2019, 04:22 AM   #5
Junior Member

No ducatis in the registry

 
Join Date: Oct 2019
Posts: 3
It's not getting fuel or spark. I checked the coils and the TPS and everything looks good. The fuel pump runs constantly, which makes me think it's the ecu as the ecu shuts down the relay after a few seconds until the bike is started.

I just purchased the DucNostics cable and downloaded the software. When time permits, I'll hook it up and see what's going on.

Thanks in advance for the help!
hydroshok is offline   Reply With Quote
Old November 8th, 2019, 03:04 PM   #6
Member

No ducatis in the registry

 
2ducs's Avatar
 
Join Date: Mar 2013
Location: Tuscaloosa
Posts: 63
I have a new 16M ecu I purchased for my ST2 years ago and didn't need it after all. I'll sell it for 220 and include shipping.
__________________
'98 ST2
'03 999s
'15 FJR1300
2ducs is offline   Reply With Quote
Reply

Thread Tools
Display Modes


Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Trackbacks are On
Pingbacks are On
Refbacks are On




All times are GMT -7. The time now is 09:12 AM.

Powered by vBulletin® Version 3.8.8
Copyright ©2000 - 2019, vBulletin Solutions, Inc.
SEO by vBSEO ©2011, Crawlability, Inc.
vBulletin Security provided by vBSecurity v2.2.2 (Pro) - vBulletin Mods & Addons Copyright © 2019 DragonByte Technologies Ltd.