Ducati.org forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello, my 900ss keeps blowing ecus. About a year ago I had a crank w no start. Found no power from the ecu to the coils and injectors. Bought a used ecu off of eBay, plugged it in, good to go. Here I am a year later w the exact same issue. Does anyone have an idea as to why? Any help is much appreciated. Thanks, Jake.
 

·
Registered
Joined
·
1,238 Posts
Check the wiring to/from the regulator/rectifier and all connections — especially ground connections. I had an 916 ECU fail simultaneously with a RR failure.
 

·
Registered
Joined
·
610 Posts
also make sure that the ground cable that attaches to one of the ecu mounting bolts is tight (this ecu is externally grounded)
 

·
Registered
Joined
·
6,787 Posts
I certainly second the above advice.

The possibility being referred to is that your charging circuit is not providing a steady current/voltage for your system. The ECU is often the most susceptible component, which might start doing strange things before the problem manifests by blowing light bulbs etc.

You need to ensure that all the earths and primary connections are clean and tight, particularly around your battery and regulator, and if necessary add a direct earth lead between the battery and the engine, as well as the indirect one (via the frame) from standard.

Compromised earth connections can have the effect of encouraging the charging system to provide too much charge, causing 'spikes' in the circuit which can cause this sort of issue.

And don't be told that it's simply the regulator, and that replacing it will fix everything. Often there is a problem elsewhere which causes the regulator to fail.

But essentially your charging system should be providing over 12V to the battery when it is running, without ever exceeding 14.6V at revs. A voltmeter across your battery terminals, with the engine running, is the simple test.

If you are getting more than 14.7V that may be the likely cause of the repeated failure of the ECUs. That means you need a regulator/rectifier, and to ensure that all the terminals are good.

But you need to run your engine to do the test..
 
1 - 5 of 5 Posts
Top