Ducati.org forum banner

1 - 20 of 23 Posts

·
Registered
Joined
·
145 Posts
Discussion Starter #1
Alright, first real curious thing I have on the bike.

After it sits for a while, like an hour or so, and even longer, like after I get out of work, I turn the key and the bike goes through the start up sequence. I hear the fuel being primed and that's where it gets odd.

The fuel won't prime. It sounds like it's starved for fuel, and then after that the fuel light comes on and stays on.

Now at first I thought okay, I rode it 100 out and back, maybe I made the idiot mistake, but upon inspection, she's half full...

Went to gas station, filled it. Second time it did this, was after that with a full tank.

If I turn the key off and back on, without starting, it primes and fires.

If I try to start it when it sounds like it didn't prime and the gas light came on, it takes longer but will fire after 3-4 seconds, but the light won't turn off.


What gives ?
 

·
Registered
Joined
·
145 Posts
Discussion Starter #3
Ehhh... Not for the low fuel sensor, as it doesn't prime the injectors the first time but it does the second time...the light comes on because no fuel goes into the injectors, triggering the fuel light.
 

·
Registered
Joined
·
122 Posts
best guess - shitty fuel clogged the line or damaged the pump. pull the fuelling system apart and give it a thorough cleaning...if this doesn't work - bring to the shop for diagnostic and probably new pump :(
 

·
Registered
Joined
·
145 Posts
Discussion Starter #6
Shortest time so far for it to repeat itself is 10 minutes. Tested it on way out of work
 

·
Banned
Joined
·
5,501 Posts
You may simply have a short in the harness going to the fuel tank. Both the fuel light AND fuel pump feeds go through the same cable. Something is most likely wrong with that cable, perhaps on the inside of the tank vs externally. Thats the only thing I can think of which makes sense since you have TWO issues which stem from the same connector.

Also, there is no fuel pressure sensor. So the bike has no idea if the injectors have fuel or not. I've been in these bikes A LOT and even with the fuel tank missing, there is no fuel light when you turn the ignition key on.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #8
I was hoping you would hear my plea tye, question is what do I do now? Is it something easy I can get to or this more involved?
 

·
Banned
Joined
·
5,501 Posts
I was hoping you would hear my plea tye, question is what do I do now? Is it something easy I can get to or this more involved?
Ya know, if its consistently not working, you may wanna take it to a dealer. I say this because even though its probably not under warranty, this is for sure a "warranty" issue and if you make a big enough stink about it, they may be able to do something. I don't think the issue is actually easy to fix without a boat load of parts at your disposal.

I had a similar issue on my 748 and found it was a faulty relay. However, the fuel light didn't go on in my case.

Lets see if anyone else has another suggestion… ;)
 

·
Registered
Joined
·
369 Posts
Could just be a pinched or misplaced fuel line. The fuel lines are under the tank. When I changed the spark plugs on my bike, which involved removing the gas tank, I forgot the proper orientation of the fuel lines when I put everything back together. This led me to have symptoms like yours.


After I rearranged the fuel lines and made sure everything looked fine like it should from factory, the symptoms disappeared.


Worth a shot before taking further action
 

·
Registered
Joined
·
436 Posts
I've had a similar experience, turned out the wire harness thru the fuel pump flange was bad. This can be a very expensive fix as you have to buy the entire assembly. I've also heard of others how claim to have replaced the wiring and re-bedded the wires with a non potable epoxy, however when asked about longevity and reliability of this repair, where they sourced the wiring, all I got was silence. As you're still under warranty take her to the dealer.
 

·
Registered
Joined
·
145 Posts
Discussion Starter #14
Well the problem hasn't gotten any better yet so it looks like it has to go to the shop. It does it now every time I turn the key, making me switch it off and on to make it stop doing that.

Blows.
 

·
Court Jester
Joined
·
11,817 Posts
Well the problem hasn't gotten any better yet so it looks like it has to go to the shop. It does it now every time I turn the key, making me switch it off and on to make it stop doing that.

Blows.
You ate under warranty stop farting around!
 
1 - 20 of 23 Posts
Top