Ducati.org forum banner
1 - 18 of 18 Posts

·
Registered
Joined
·
979 Posts
Discussion Starter · #1 ·
just installed full system on my 1299S
sounds great, only thing that sucks is dealer has to do the damn upmap. sucks, but sounds like a boss, really nice looking too, ill snap some pics on daylight tomorrow.

-Carbon
 

·
Registered
Joined
·
7 Posts
Im installing a full Akrapovic system on my 1299S as well. Two questions if you don't mind.

1) Did you remove the rear sub frame like the instructions said and if you did do you have to remove your shock to get at the Torx bolt on the left side?

2) Any tricks for getting that front bolt off the front header?

Thanks,

Nick
 

·
Registered
Joined
·
979 Posts
Discussion Starter · #7 ·
I did remove bolts on rear subframe to lift it up, on front bolts, I removed the 3 screws holding the fan shroud and dropped down the evap canister and with a long extension and swivel I could get to front headers without hurting fins on radiator.
also remove the guard that holds tank in place to lift the rear subgrame higher

only downside is dealer has to install upmap, but once they do, it shows ducati logo then racing evo then your screen

don't forget to take out the baffles on the system too. ill see if my crappy phone can take some decent pics

-Carbon
 

·
Registered
Joined
·
979 Posts
Discussion Starter · #8 ·
Here are some pics, also have the R&G tail tidy and worked good with existing heat shield, ill never cut out the heat shield for the pegs.

-Carbon
 

Attachments

·
Registered
Joined
·
979 Posts
Discussion Starter · #14 ·
dealer did upmap, before upmap bike ran rough with new full system, after upmap, it feels like the bike doubled in power, cant keep the front wheel down it seems, huge power boost. no dyno figures yet though

-Carbon
 

·
Registered
Joined
·
1,735 Posts
dealer did upmap, before upmap bike ran rough with new full system, after upmap, it feels like the bike doubled in power, cant keep the front wheel down it seems, huge power boost. no dyno figures yet though

-Carbon
Double??? God damn 387hp on a stock motor with just exhaust and a tune is pretty impressive lol
 

·
Registered
Joined
·
1 Posts
just installed full system on my 1299S
sounds great, only thing that sucks is dealer has to do the damn upmap. sucks, but sounds like a boss, really nice looking too, ill snap some pics on daylight tomorrow.

-Carbon
Good morning man. Need HELP!!!

I just got my Akra Full Exhaust System for my 2016 Panigale S, now bike won't start at all. Battery is good 12.7v. Did not mess around with the computer system at all. Also the engine light turned on.
 

·
Registered
Joined
·
979 Posts
Discussion Starter · #18 ·
did you miss a connector or lambda sensor? mine started before i could get ump done at dealer but just ran roughish

check fan connectors etc, i pulled all that stuff out and also eliminated my charcoal canister but sounds like something is loose or not plugged in

-Carbon
 
1 - 18 of 18 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top