Ducati.org forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
14 Multistrada 1200GS. First ride in a few months, and:

speedo reads 0 all the time

odometer not increasing (wooo!)

ABS warning

I'm pretty sure all signs point to speedometer / ABS sensor. I'm also pretty sure that ABS relies on both front and rear wheel sensors so that isn't a clue as to which might be bad - but does anyone know if the speedometer gets its signal from just the front (if so that's likely the bad one).

Anyone here replaced one of those before?vidmate mobdro


thanks!
 

·
Court Jester
Joined
·
12,025 Posts
14 Multistrada 1200GS. First ride in a few months, and:

speedo reads 0 all the time

odometer not increasing (wooo!)

ABS warning

I'm pretty sure all signs point to speedometer / ABS sensor. I'm also pretty sure that ABS relies on both front and rear wheel sensors so that isn't a clue as to which might be bad - but does anyone know if the speedometer gets its signal from just the front (if so that's likely the bad one).

Anyone here replaced one of those before?

thanks!
I'm going to go with a guess that the rear is the primary for the speedo display. I've converted one of my bikes to a corse adding a new wire harness with a speedo sensor for the front wheel for the DTC.

I've got an 848 so parts are different but I bet you could find a used speedo on ebay plug it in install without running the wires. Get the back wheel on a stand and see if your speedo is registering you can just hand spin the wheel and it should show a couple MPH..
 
1 - 3 of 3 Posts
Top