Ducati.org forum banner
1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 ·
Hi all!

I had some really difficult problems with my '07 ducati 1098.
Very slow cranking and other electric troubles.

Because the wiring harness off the bike was very bad (previous owner cute off some plugs) i decieded to completely replace the whole wiring harness.
Now i have replaced the wiring harness but I do have some strange issues, every plug is connected right by now.
Battery is good as new and contains about 13v, when i start the bike everything is working, lights go on and i can hear the fuel pump buzzing.

When i press the starter button nothing happens, only the headlight will turn off for around 10 seconds.
I measured the round starter solenoid when pressing the starter button but it doesn't do anything, it shows 0 v.

As every plug is connected as it should be I have 3 plugs un-connected.
At the right side (clutch side) I got a plug with an label ''front speed''' not connected.
Also at the back off the bike I got an 6-pin white connector with no label.

I think the wiring harness is coming from an 1098 with DTC control?
The DTC unit is located at the back off the bike so that complains the white 6-pin connecter and the front speed connector.

I also have an plug under the battery not connected because I really don't know what this plug is for.
Have added a picture off this plug, hopefully someone knows where this should connected to.
172187
 

·
Registered
Joined
·
610 Posts
Not for a 2007 1098 for sure. Just checked mine and all that is that region are R/R side stand and diag

At this point look for a original 2007 harness or (gulp) go for the DTc conversion
 
1 - 2 of 2 Posts
Top