Ducati.org forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey guys, first time posting, I have a 2010 Ducati 848 that's done around 30,000km. Tonight it started doing something a bit strange. I turned it off to refuel, then turned the key to start it and the yellow engine light lit up and the bike wouldn't start. So i switched they key off then back on and hey presto the engine light was gone and it started find.

What's strange is that when I tested it, it did it consistently like 4 times in a row i.e.
1) Turn key off from Idle.
2) Turn key back on (engine light, won't start)
3) Turn key to off then on (light gone, will start)

Any ideas why it would be doing this, it's not a major problem, just hope it won't get to the point it won't start at all. Thanks!
 

·
Registered
Joined
·
2,127 Posts
Welcome to the forum!

When you say "doesn't start" what does that exactly mean?

Do you hear the fuel pump prime?
Do you hear the starter solenoid click?
Do you hear nothing at all when you pushed the starter button?

Also, did the bike sit for a while between this ride and the last? Was it wet by chance?
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #3 ·
Well after the key is in the on position, I push the start button and it's just nothing, no engine sounds whatsoever. And it has been ridden fairly frequently but yes, I had ridden through the rain only an hour earlier (when I say ridden, i mean pulled over by the cops on the side of the highway in the rain :/

Thanks
 

·
Registered
Joined
·
2,127 Posts
Probably needs to dry out... water and Ducati's aren't very good friends. :(

Ducati's and cop's don't get along either. :(
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Hahaha yeah up to now I've been a bit more fearful of Ducati mortal enemy number 1 (cops) but will have to take some care with water. I haven't had the bike play up since that night so hopefully that's all it was.
 
1 - 5 of 5 Posts
Top