Ducati.org forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
83 Posts
Discussion Starter · #1 ·
i have an issue i can't figure out. when i turn the key on i can here the fuel pump prime and all but when it starts it doesn't stay on. only for a few seconds. then i can't get it started. so i have to turn the key off and then it primes again and the process starts over and over. does anyone know what the issue could be. thanks
 

·
Registered
Joined
·
1,408 Posts
The fuel pump supplies fuel under pressure as long as the crankshaft is turning. For safety, the pump is switched off by the ECU (via a relay) after about five-seconds if the crankshaft stops turning. During the start sequence, the pump is run long enough to pressurize the fuel lines then stopped by the computer awaiting the signal that the engine is running/turning. Then the computer turns the pump on again.

So, if the crank rotation sensor gap is incorrect such that it grows too large at temperature to send a signal, the ECU will think the engine is stopped and shut off the pump. A cracked engine casing will also cause the gap to be incorrect at temperature.

If the sensor-ECU wiring or the sensor itself is faulty this can also result in pump shut-off.
 

·
Registered
Joined
·
81 Posts
I heard that sometimes the fuel lines disconnect inside the tank. Like where they are connected to the fuel filter etc.. If you look in the tank and turn they key you may see some splashing around, if so take the pump out of the bottom of the tank and re connect the lines.
 
1 - 4 of 4 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top