Ducati.org forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
38 Posts
Discussion Starter #1
Hello. I'm new to this forum and I recently installed the new Full Termi 70mm kit for my 848EVO. The kit included a DP ECU, Intake, Pipes, CF Heatshield, and CF Canisters w/DB Killers.

I haven't taken it to the dealer yet to perform the TPS reset, and all ECU related tuning for this kit. The appointment is set for next week.

For those of you with the new 70mm Full Termi Kit (Angled tips) and DP Race ECU installed: What does your HUD read out when you switch the ignition to the ON position on your bike after installing the DP ECU along with the Full Termignoni kit?

I've seen the words "...RACING" to signify that a DP ECU has been installed, but on mine it reads "TS848EVO B3D".

I was hoping to see "848EVO RACING..." or something similar. Is this read out normal for my kit?

All physical connections have been verified and confirmed to be correct. The bike fires up with no CEL and idles smooth and normal. It runs perfect too.

I'm just hoping this is normal and to be expected with the New Termi 70mm kit & DP ECU for my 848EVO.
 

·
Registered
Joined
·
333 Posts
Maybe the Dealer will apply this info with TPS reset? i too would like to know as i am keen to buy Termi aswell, did you you get full system or just slip ons?
 

·
Registered
Joined
·
68 Posts
i too installed a full termi on my EVO over the winter. And my start up message reads "TS848EVO B3D" too. asked around and no one could give me an ans. bike is still running the way it should do i guess its all good .;)
 

·
Registered
Joined
·
165 Posts
mine reads 848 RACING when i turn the key on. my exhaust was installed at the ducati dealer where the bike was bought. i had it installed before i even got to the dealer to pick up the bike.
 

·
Registered
Joined
·
333 Posts
Yeah i spoke to Dealer on the weekend and they acutally program this TEX info in guys.... so best to ask them to do it, lucky for me ill most likely get them do do the install as they look after me rather well =)
 

·
Registered
Joined
·
38 Posts
Discussion Starter #7
I took the bike for a test run on Sunday at my usual route here in SoCal. The bike runs great, no CEL's, and no stalling issue. In fact, it runs like a dream. My appointment to take in is Tuesday, The 24th to have them reset the TPS sensor and go over the install to make sure I haven't overlooked anything. Track day is this Friday, The 27th at Chuckwalla Valley Raceway, so I want to make sure all is well with the bike so I can maximize my time at the track with other fellow riders in my group.

I have a slight hunch it may be a TEXT only programming issue (I hope), but we'll see what they say after tomorrow. I'll keep you guys posted on the findings.
 

·
Banned
Joined
·
1,161 Posts
The dealer can program the text. You can have them say anything you want. I believe you can have as much as 16 characters of text so chose wisely.

Cpt DB
 

·
Registered
Joined
·
38 Posts
Discussion Starter #10
Just got back from the dealer and everything is fine :)

The startup text "TS848EVO B3D" is to be expected for the new 70mm Full Termi System utilizing the DP ECU for the 2011 848EVO. The startup text can be modified, but I decided to keep it at that.

They scanned for any fault codes, verified all physical connections (electrical, mechanical, and data), and everything checked out fine.

They reset both the TPS and the bike's self adaptive learning routines and took it for a test ride. Bike fires up with no issues, idles very smooth, and the bike breathes a lot more efficiently than before (Pulls STRONG).

As I tape up my lights, wheel weights, speedo, and remove everything I possibly can for Track Prep for this coming track day (Friday, May 27th) at Chuckwalla Valley Raceway, I would like to thank you all for your input, advice, and help on this.

I truly appreciate you all!

-J
 
1 - 10 of 10 Posts
Top