Ducati.org forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
What's up everybody? I went out for a ride the other night when all of a sudden my check engine light came on and then bike started bucking and would not rev past 3k rpm. Stopped turned bike off then back on and no more CEL or rpm issue but now my total miles on bike is flashing all dashes instead of showing my bikes total miles. Any ideas on what the problem is or if I am not doing something right with controls?
 

·
Registered
Joined
·
472 Posts
What's up everybody? I went out for a ride the other night when all of a sudden my check engine light came on and then bike started bucking and would not rev past 3k rpm. Stopped turned bike off then back on and no more CEL or rpm issue but now my total miles on bike is flashing all dashes instead of showing my bikes total miles. Any ideas on what the problem is or if I am not doing something right with controls?
Your likely looking at 2 separate issues...next time the check engine light comes on try changing engine modes...I suspect your throttle is kaput....the dashes...if they don't go away...are because you have done 10 miles worth of wheelies or spun the rear 10 miles more than the front...only way to fix it is a dealer visit to resync the dash to the BBU
 

·
Registered
Joined
·
20 Posts
Discussion Starter #3
Thanks for the quick reply.
I have never done a wheelie before on any bike and never smoked the rear tire either.
The throttle issue, is it an expensive issue or can I do it myself?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
Also forgot to mention that I installed a K&N filter and power commander V a cpl weeks ago. Rode about 400 miles since with no issue.
 

·
Registered
Joined
·
472 Posts
Thanks for the quick reply.
I have never done a wheelie before on any bike and never smoked the rear tire either.
The throttle issue, is it an expensive issue or can I do it myself?
While not free...it's a very easy fix...do a forum search for "eng err" and order a security torx bit t-25 to remove/replace the unit
 

·
Registered
Joined
·
472 Posts
Also forgot to mention that I installed a K&N filter and power commander V a cpl weeks ago. Rode about 400 miles since with no issue.
What year is your bike and what size tire do you use...the dashes just mean the the rear tire is out of sync with the front by 10 miles....if you go through rears more than the fronts or run a 55 series tire not a 60..over enough time a difference of 10 miles can easily accrue...I don't believe the add ons have any relevance to your current issues...just coincidence
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
2015 monster 821. I did put a 55 size on the rear back in August and put about 750 miles since. Was told it would not be an issue.
 

·
Registered
Joined
·
472 Posts
2015 monster 821. I did put a 55 size on the rear back in August and put about 750 miles since. Was told it would not be an issue.
2015... definitely the throttle.... original owner? A little maths and I'll tell you how many miles a 55 series will go before it's 10 miles short of a 60...


Ok... assuming it never wears or at least wears proportionally equal...a 60 series tire has a circumference of 80.123 in and a 55 series tire is 77.896 in....that means the 60 series tire will rotate 790.784 times per mile and the 55 series 813.39...a difference of 22.606 rotations...now if that's accurate your dash should turn to dashes in only 360 miles...because the difference between the two is 1760.917 in/mile so it will take 360 miles to out rotate the 60 series by 10 miles

Factor in tire pressure and it's not going to be a stretch to get to 750 miles. ..bottom line...don't reset the dash until your next set of tires....
 

·
Registered
Joined
·
20 Posts
Discussion Starter #9
Nice, you know your @#$%. Thanks for the help. Going to leave it until spring season and then put a 60 tire on. As for the throttle, should I take it to the dealer and have them check it out or just buy the part and install it myself? If so do you know the exact part I have to get?
 

·
Registered
Joined
·
472 Posts
Nice, you know your @#$%. Thanks for the help. Going to leave it until spring season and then put a 60 tire on. As for the throttle, should I take it to the dealer and have them check it out or just buy the part and install it myself? If so do you know the exact part I have to get?
You can absolutely do this one yourself...it's plug and play...no dealer needed...either just buy the new one or... wait until it trips again....try and change engine modes...check the error message in the sub menu...all before you turn the bike off...the throttle resets it's position every time the bike is powered on...and a failing unit gives a garbage signal which trips the bike into limp mode...unless it's completely toast it will clear the error everytime the key is cycled...I'm near positive this is the issue..but it's easy enough to do a self diagnosis...part# 66020051H...I don't know where your located but it's considerably cheaper if you buy overseas...even factoring shipping and exchange rates...not affiliated in any way...just very happy with their service

Startwin.com or oemducati.com...same place..it's even more economical if you get two things
 

·
Registered
Joined
·
472 Posts
I live in Connecticut. Thanks again for taking the time to answer my questions dude!!!
A real helpful hint is to install the grip...then plug it in...the spring in the throttle will drive you to drink trying to get it right while on the bars...keep it loose...then slide it on...get it to seat in the index hole...tighten it up...then plug it in...takes minutes...and you need a t-25 security torx to remove/install...always happy to help


And save the old one...the throttle tube is a welcome accessory if you ever want to run heated grips
 

·
Registered
Joined
·
20 Posts
Discussion Starter #13
Real quick, I looked up the part on oemducati.com and it ends in an F not an H, does it matter?
 

·
Registered
Joined
·
20 Posts
Discussion Starter #17
How do I find out about this Goodwill assistance? I have no idea when the original date of purchase was. Second owner.
 

·
Registered
Joined
·
2 Posts
What's up everybody? I went out for a ride the other night when all of a sudden my check engine light came on and then bike started bucking and would not rev past 3k rpm. Stopped turned bike off then back on and no more CEL or rpm issue but now my total miles on bike is flashing all dashes instead of showing my bikes total miles. Any ideas on what the problem is or if I am not doing something right with controls?
Had a very similar situation- sounds identical to what happend to my bike....happened once and it was short lived, but months later the second time required replacement of the throttle- It was covered under warranty, so took it to dealer!!
 

·
Registered
Joined
·
20 Posts
Discussion Starter #19
Unfortunately I am out of warranty so going to have to purchase a replacement and install myself. Going to wait until spring to do it.
 
1 - 19 of 19 Posts
Top