Ducati.org forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
1,389 Posts
Discussion Starter #1
My battery is new as of last year and I kept it on a tender all winter and now the bike is having a hard time starting. Usually need to give it a jump to get it started but once it's ran for a few miles it would start no problem. But now even after being on a tender and even tried to jump the battery it won't start. The battery would read over 12 amps and it would just click. So now do I buy a battery or replace the regulator? Or is there a way to test the voltage regulator?
 

·
Registered
Joined
·
248 Posts
Easiest test, I've heard, is to ride it until it's hot, then check the voltage. it should be approx 14.4V - bad reg will routinely show 16+V when hot.

Also bike should maintain that 14.4V while revving. If you're at 14.4V at idle, but it spikes while revving, also a regulator issue.
 

·
Registered
Joined
·
1,389 Posts
Discussion Starter #3
Now only if I could get it to start.... Battery ready 12.1 on the dash everything lights up normal but it only clicks once and nothing happens. The bike is in neutral so not sure the kickstand switch would affect it but I'm gonna go jump that and see.
 

·
Registered
Joined
·
248 Posts
Now only if I could get it to start.... Battery ready 12.1 on the dash everything lights up normal but it only clicks once and nothing happens. The bike is in neutral so not sure the kickstand switch would affect it but I'm gonna go jump that and see.
12.1 is right on the limit. I would lean towards battery issue here as, generally, the VR doesnt mess with you when its cold (generally...there are exceptions!).

How old is the bike? Battery?
 

·
Registered
Joined
·
1,389 Posts
Discussion Starter #7
12.1 is right on the limit. I would lean towards battery issue here as, generally, the VR doesnt mess with you when its cold (generally...there are exceptions!).

How old is the bike? Battery?
Bike is a 2011 and the battery is a year old to me. But I guess I don't know how long it sat around for. I was thinking the same thing so I'm gonna order one tonight.
Thanks for the suggestions guys.
 

·
Registered
Joined
·
50 Posts
I'm dealing with same issue! Just dropped mine off at the dealership! Hopefully I can share with everyone


Sent from my iPhone using Ducati.org Forum
 

·
Registered
Joined
·
1,490 Posts
VR should not come into play just starting the bike. If the battery is good the bike should turn over no problem even if the reg is shot. The problem will be, not charging, or, over charging with all The symptoms that go with that, headlights going out dash flashing off all when the bike is hot. Do a search there is some stuff on youtube.
Just because the battery is reading 12v doesn't mean it's any good it needs to be load tested to check if it's any good. Also check your battery connections if your only getting a clicking sound at startup.
 

·
Registered
Joined
·
1,113 Posts
^this is totally correct! It doesn't matter what the voltage is when sitting- it matters what the voltage is under load. Pull the battery and have it load tested
 
1 - 10 of 10 Posts
Top