Ducati.org forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
57 Posts
Discussion Starter · #1 · (Edited)
just picked up my 2013 848 has bazzas fuel management and akropovic slip ons before tune no issues at all with slip on installed no on my way home after tune On a super hot!! day and humid my bike stalled 3 times at lights and rpm seems to be at 1100 and throttle response is terrible might be the heat ?? bike is cooling off will ride later tonight too see any change , any help with this would be great !
 

· Registered
Joined
·
57 Posts
Discussion Starter · #3 ·
yes just had it installed in Canada and tuned now bike has a terrible idle and stalls and throttle response at idle is vey bad almost stumbling bike will restart but very low idle 500 then up to 1000 maybe 1200 my bike always idled at 1350 or 1400 before tune which I believe is correct
 

· Registered
Joined
·
57 Posts
Discussion Starter · #6 ·
they dynoed the bike after installation , bike is bak at shop they are now saying its a secondary O2 sensor on my bike which I find funny that the bike ran fine the day I took it too them in any even I told them if they cant find any issues to take the bazzas out put back too stock ! I am so pissed off and expected this to work perfectly and has been a real nightmare !
I knew they would say its something else wrong with a perfect bike that according to them ran fine while dyno but 5 min after leaving the shop died 5 times on the road
 
1 - 3 of 3 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top