Ducati.org forum banner
1 - 3 of 3 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hi Everyone,

This is my first message as my first bike.

I bought it used, Monster 821 - 2016 - Dark. Apparently all original parts. I do love the bike and the sound and I am learning every day with her.

One thing that makes me losing my mind, my bike doesn't show the cooling liquid temperature on the instrument panel.

On my 821 the little indicator in the middle is completely absence. Nothing, not even the error display on mulfucntion.

Anyone can help me to figure this out?
Speedometer Odometer Automotive tire Automotive lighting Trip computer
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #6 ·
Well, there is a coolant sending unit/sensor. These are often located on the left side (seated) in an external hose junction block. Normally this sensor runs off a 4-20mA current loop. If you possess a DMM(digital multi-meter), you can unplug the sensor and connect a few crude jumper wires. You can then observe the sensor output as the bike warms up. Be sure your meter leads are in the correct sockets(Amps) and setting is milliamps on the dial. The base reading of 4mA corresponds to LO and 8mA is 25%, 12mA is 50%, 16mA is 75% and 20mA is 100% of the temp. scale(any temp number is possible between these values). Clusters have the scaling factors programmed inside, so I cannot know this data, As the engine warms this sensor should linearly move up and probably operate around the mid range of 12-14mA.
If the sensor is working, move on to the harness and plug connections(clean them with a good electrical cleaner). Sorry for the complicated response.

Oh yeah, is your cooling fan cycling on and off properly? Sometimes, the same sensor will run the fan and is triggered by a certain temperature output.
Hi Buritopp,

Thank you for you comment, I am afraid I won't be able to do that, I don't even have a DMM but I will look for it and I will have a look to the sensor you are talking about. If you are able to send me a photos or anything to recognize this sensor will be great.

Today I had a 20km ride and the fans didn't operate.. Actually, I never put attention to it but I never heard the fans working since I took the bike. I suspected that there was even no coolant inside because I wasn't able to check the level as I can't see clearly what's the level in the plastic tank on the right side of the bike, even at night with a light on. Today, I have opened the radiator cap and it's surprisingly full.

The funny thing is that I never felt the bike get too hot. I rode in the past other 821 and in some of them the hot was unbearable in other was normally hot. The temperature in my bike it's just fine never felt high temperature coming up from the engine.

The instrument panel beside the missing information seems just fine and all works's fine.
 
1 - 3 of 3 Posts
Top