Ducati.org forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Hello all! I've been lurking and learning for a while, but this is my first post/ cry for help.
I have a 2006 999s with 4000 miles and am totally loving the experience. However, on my way to work last week, it threw a CEL on a back road. I stopped and tried to Check for a code, but got nothing. I restarted with no CEL and went on my way. The CEL came on and went off 2 or 3 more times. On the ride home, I filled up and got nothing. Now, It will throw random CEL's and turn off on almost every ride, but still nothing from the ECU as far as codes......
The bike runs perfect and all checks out in the garage. Not due for service for a while yet and would rather not head straight to the dealer if I can resolve on my own.
Anyone have any thoughts?
Thanks!
 

·
Registered
Joined
·
6 Posts
Discussion Starter #2
Got it!

Well, These things never seem to get better. Which in my case was a good thing. The CEL stayed on last weekend and the bike was prone to stalling. Got home and was able to see EOBD Code 4.2 Air Temp Sensor Shorted to earth....

Opened up the headlight bucket to check sensor and found 4 ridiculously frayed wires! two leading to the Air temp sensor and two leading to the high beam!

Replaced wires - Problem solved. I can't believe how bad these wires were in such a new bike!

Hope this helps the next guy!

Cheers!
 

Attachments

·
Registered
Joined
·
6 Posts
Discussion Starter #4
I was thinking about all of the recent headlight malfunction posts as well.....
I wrapped the harness in a high temp tape, but I would like to insulate it better if I can come up with a better wrap.
 
1 - 5 of 5 Posts
Top