Ducati.org forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
211 Posts
Discussion Starter · #1 ·
Hello all

I have this issue lately, as i am in 2-3-4th gear accelerating hard, at around 9k the revs stop increasing... releasing throttle and again doesn't help it still stops there. only at second gear it manages to pass 10k but really hard. at lower rpm there is no power loss. its like there is a rev limiter.

it doesn't also do it all the times. i thought it was bad gas and used some 100 octane and thought it was fixed but it does it again randomly, but i have to switch on and off the bike to change situation.

I recently installed full termis with ecu and had tps reset and co set etc. could it be a fuel filter or something easy?
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #3 ·
no no... not even the first light comes up. as i said its around 9k, and the behaviour isn't like limiter's cutting, its like i keep the gas steady at 9.

i am suspecting the fuel filter and i will change it (its been 10k kms) but i asked if it could be something else not allowing power, electronic or anything

edit: by the way we re talking about a 2007 1098s
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #6 ·
hello thanks for the reply.

i am in the process of changing the fuel filter and cleaning the small net on the pump entrance, i have it all disassembled now. though searching for the fule net thing, i found this thread:

Changed my fuel filter and... - Ducati Superbikes

which is exactly what mine does without the cracling sound this guy says. seeing that, i removed the air intake etc and refitted the air filter, without noticing anything out of the ordinary or damaged. could be something loose on the throttle bodies, but i didnt go that deep.

i will put the new filter today and if its not fixed i will take it to the shop for pump measurement or further investigation. i will let you know what it was, tho i suspect the cut at 9000 comes from various reasons as safety from the ecu, and i hope its just the filter because i am starting to be fed up with these stuff 2 years now this thing doesnt run for 1000km without asking for something. cheers
 

·
Registered
Joined
·
211 Posts
Discussion Starter · #9 ·
thanks everyone, i will check the sensor as well.

as for the climate i am in greece right next to italy and i ride it often. it doesnt sit fir more than 4 days. the roads here suck so that causes many problems as well (for example the right suspension boot started leaking - not the seal, the bottom part - right after i changed oil and seals !!!).

anyway. i like it too much to sell it tho so i am just patient :)
 
1 - 5 of 5 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top