Ducati.org forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Just got an 07 1098s mint condition, 1800 miles. The thing was basically dropped on my lap for such a low price that i had to bite. I have put about 600 miles on it so far and all the sudden while in first gear, the thing cuts out on me. The starter just clicks and won't turn over, you can see the clutch move just a tiny bit and it feels like its stuck. Put a new batter in it and the thing starts right up, so i thought maybe it was the old battery. Nope, cuts out again after about a 2 weeks and same thing happens it won't start. Threw it on a charge and the thing started right back up again, but the battery terminals were so damn hot i burnt myself. can someone please tell me what could be the issue and why this bike keeps breaking down? The voltage regulator had the recall done already, It has a full exhaust and ECU with air filter. Im losing my mind.
 

·
Registered
Joined
·
632 Posts
A really good new battery may be hiding the real problem, I went through this pain & it turned out the sprag clutch was shagged.

If its not electrical, it must be mechanical.

Craig
 

·
Registered
Joined
·
11 Posts
Have you checked the connections at the starter solenoid for corrosion ? Mine where green. Bike was perfect after cleaning using electrical contact cleaner and an abrasive pad. Also, carefully check for signs of corrosion at the two relays behind the battery tray whilst you're in there.
 
1 - 7 of 7 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top