Ducati.org forum banner

1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
:violin:Greetings Ducatistas!
Early February 2012 I bought my first Ducati, a 2012 Monster 696 in Minneapolis, Minnesota. The dealer treated me well, the bike . . . a dream! Certainly I began to customize it based on my own likings and their suggestions. About a month ago, everything seemed to have changed with the dealer and more importantly, with my Monster. Suddenly my digital speedometer stopped showing the speed, the after market gear indicator stop working as well and, they ABS light remains on ( meaning that the ABS is no longer functioning). The bike obviously ended up at the Minneapolis dealer for repairs. They seem to have known what the issue was, a wheel speed sensor. Off course the after market gear indicator was blamed initially - although they still kept in mind the wheel speed sensor. The repair seem not going well, it took them two weeks or so to 'repair' it by switching the sensor. Well, today - one week after I received it 'fixed' the issue appeared again!!! So, sort of knowing the mechanics a bit - seem sharp at what they do - I suggested that being as good as they are, they probably should simply contact the Mother Ship Ducati letting them know of what is happening with my bike. I felt uncomfortable with the bike but thought that I was just being unreasonable. I guess Never overlook gut feelings .. . . now I have to take the next step and not just notify the dealer once again, but a National Transportation Division. And, I will have to contact the Mother Ship myself. I have been having the feeling that I am 'bothering' the dealer with MY bike electrical problems. Stay tuned, will see how the saga continues.
Axel
 
1 - 1 of 1 Posts
Top