Ducati.org forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello,

Riding about a week ago and the engine on my 2006 St3s quit. Had just refueled, engine temp good, no pops - dings or odd noises prior to engine shut down.

It just stopped running. (makes me think electrical issue)

All lights and information panel work correctly. Sounds like the fuel primer is working when I turn the key. Checked the fuses that I found and all seem to be okay. Also pulled one of the two coils, reconnected - pulled a plug, grounded and got an orange spark from the spark plug when I tried to start.

Has anyone experienced the same type of issue?

Is there an easy way for me to tell if it's actually getting fuel?

I found two fuse boxes - one in the left front and one under the seat. Are there any others that I might have missed?

Thanks for any feedback or ideas.

St3s Jim
 

·
Registered
Joined
·
1,020 Posts
Not sure of the specifics on your bike, but perhaps the fuel line popped off from the filter/pump. Effectively makingit seem as if the bike had run out of fuel. And if all the electricals are good, this would definitely be worth checking into.

If it is a popped off line, get some screw type fuel injection specific clamps to replace the shit clip on type clamps that come stock on many of these.
 

·
Banned
Joined
·
5,501 Posts
If the kickstand safety switch is unplugged or damaged, the bike will not start. Thats why it happened to you at the gas station, because you probably put the kickstand out… Just a hunch.
 

·
Registered
Joined
·
1 Posts
There's a small relay that causes mayhem to all sorts of electrics. Left side (sat on the bike) under the fairing inner cover.
 
1 - 4 of 4 Posts
Top