Ducati.org forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1 (Edited)
Hi. New to the forum but not to Ducati (on my fourth) nor to riding (40+ years).

My issue: 2009 1198, starts and runs great (even with 29,000 kms). It has a new voltage regulator.

Usually it starts without issue and, like I mentioned, runs great.

But last week, I rode it to the grocery store, was in and out in about 5 minutes, and when I came back it wouldn't start. The instrument panel lit up, lights and horn all fine, but it won't turn over. After trying intermittently to crank it over 2 hours, it started. No problems for 10 days and then ... it won't start again.

I realise it cannot be a fuse, so it must be a short either in the kill switch or else the electrical harness.

So my question is, where on the bike should I start looking - I am a rider, not a mechanic, and taking it in to the dealer will cost a minimum of $500 - so if it's something simple (and I mean REALLY simple), I should at least try to save some money and do it myself.

Grateful for any assistance.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
Hey guys, thanks for the responses.

An update:
The fuses are good. The battery is a little low. Now, everything lights up, horn works, lights and turn signals ok ... hit the start button and nothing - but the lights go out ... eventually they come back on, but if you hit the start button again they go out again. Note: this happens whether the run
switch is set to run or kill ...
 

·
Registered
Joined
·
1,665 Posts
how about cleaning all the ground connections...
how about the sprag clutch (you will have to take the side cover and a few other things off to check though)...
 

·
Registered
Joined
·
5 Posts
Check your starter/fuel pump relay, test rode my new, at least to me, on Saturday, also didn't want to start, and the guys in the workshop changed the relay, and started first time.
 
1 - 12 of 12 Posts
Top