Ducati.org forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1 (Edited)
Hello everybody,

I've recently bought a used 07 ducati 1098 and is having some major stalling issues.

It only stalls when the engine is warmed up. It idles at 1300 to 1350. Its got an aftermarket slip on with stock ecu. It stalls at idle or coming to a stop or stopped everytime...

Here is what I have tried so far...

I adjusted the air bleed screws, it was set at 1.5 turns on the front, 1/8 of a turn in the back. I adjust it to 1400 to 1450 idle, which took like 6 or 7 full turns. it did seem to help with the idle problem initially but it soon come back. The idle stayed at 1400 for a day or so, but the next day went back down to 1300 idle for some reason... anyone know why?

Also, once the bike dies, I have problems getting started back up right away, twice which required recharge of the battery to even restart it. I did buy a new battery with more cca which I have't yet installed.

I bought a fat duc and vdst but they are not here yet, would fat duc help? What are my options?

btw, all the recalls are already been done, and i do have a battery tender.

Thanks
 

·
Registered
Joined
·
276 Posts
Check tank vent for blockage. Or when it stalls, open the gas tank lid and listen for a whoosh of air going into it. Then try starting again. If it's easy to start or there's a whoosh sound, you're developing a vacuum in the tank and preventing fuel from getting to the motor.
If that doesn't work, come back ;)
 

·
Registered
Joined
·
278 Posts
Has the TPS been reset?
This would be my first base line.

This is the point where the ecu 'thinks' the throttle is closed, if wrong the bike will stall often, especially as you roll off or to a halt. Dealer can do this for 1/2 hour I'd estimate.
 

·
Registered
Joined
·
3,533 Posts
Hello everybody,

I've recently bought a used 07 ducati 1098 and is having some major stalling issues.

It only stalls when the engine is warmed up. It idles at 1300 to 1350. Its got an aftermarket slip on with stock ecu. It stalls at idle or coming to a stop or stopped everytime...

Here is what I have tried so far...

I adjusted the air bleed screws, it was set at 1.5 turns on the front, 1/8 of a turn in the back. I adjust it to 1400 to 1450 idle, which took like 6 or 7 full turns. it did seem to help with the idle problem initially but it soon come back. The idle stayed at 1400 for a day or so, but the next day went back down to 1300 idle for some reason... anyone know why?

Also, once the bike dies, I have problems getting started back up right away, twice which required recharge of the battery to even restart it. I did buy a new battery with more cca which I have't yet installed.

I bought a fat duc and vdst but they are not here yet, would fat duc help? What are my options?

btw, all the recalls are already been done, and i do have a battery tender.

Thanks
Get a DP slipon ecu or a micro-tec ecu
Your co level is to low!!!
 

·
Registered
Joined
·
2 Posts
Discussion Starter #6
Thanks for the tips so far. Now does anyone know why the idle dropped back to 1300 even after the adjustment of the air bleed screws? How about the fat duc o2 manipulator?
 

·
Registered
Joined
·
3,569 Posts
Well I'd guess that like most modern day fuel injection the computer adjusts to the new air density so opening up the bleed screws would initially make a difference but your cpu probably adjusts after a few starts.
 
1 - 7 of 7 Posts
Top